Failed to bind properties under 'server.address' with helm
05:04 14 Nov 2025

I want to deploy my app on kubernetes with Helm

I have a Ingest Service running with spring boot that is made of two parts

  • Fiprocessor

  • Io

Both of this part use the same deployment file and the same Service

spec:
  replicas: {{ .Values.ingest.replicas }}
  selector:
    matchLabels:
      app: ingest-{{ .Values.global.branch }}
  template:
    metadata:
      labels:
        app: ingest-{{ .Values.global.branch }}
    spec:
      containers:
        - name: fileprocessor
          image: "{{ .Values.ingest.fileprocessorRepository }}:{{ tpl .Values.ingest.tag $ }}"
          ports:
            - containerPort: {{ .Values.ingest.fileprocessorPort }}
          envFrom:
            - configMapRef:
                name: tryphon-config-{{ .Values.global.branch }}
        - name: io
          image: "{{ .Values.ingest.ioRepository }}:{{ tpl .Values.ingest.tag $ }}"
          ports:
            - containerPort: {{ .Values.ingest.ioPort }}
          envFrom:
            - configMapRef:
                name: tryphon-config-{{ .Values.global.branch }}
---
apiVersion: v1
kind: Service
metadata:
  name: ingest-{{ .Values.global.branch }}
  namespace: {{ default .Release.Namespace .Values.global.namespace }}
spec:
  selector:
    app: ingest-{{ .Values.global.branch }}
  ports:
    - name: fileprocessor
      port: {{ .Values.ingest.fileprocessorPort }}
      targetPort: {{ .Values.ingest.fileprocessorPort }}
    - name: io
      port: {{ .Values.ingest.ioPort }}
      targetPort: {{ .Values.ingest.ioPort }}

i use the value.yaml file to overwrite the server.address for both of them and point it toward the service

  FILEPROCESSOR_ADDRESS: "ingest-{{ .Values.global.branch }}"
  IO_ADDRESS: "ingest-{{ .Values.global.branch }}"

In my properties file for both FileProcessor and Io i used spring variables

server.address=${FILEPROCESSOR_ADDRESS}
server.address=${IO_ADDRESS}

Everything work fine in minikube for testing but when i push on the kubernetes my FileProcessor doesn't work anymore


 Failed to bind properties under 'server.address' to java.net.InetAddress:
    Property: server.address
    Value: "fileprocessor"
    Origin: URL [file:/config/fileProcessor.properties] - 6:16
    Reason: failed to convert java.lang.String to java.net.InetAddress (caused by java.net.UnknownHostException: fileprocessor: Name or service not known)
kubernetes kubernetes-helm