i want to mount a raid1 with 2x 4TB btrfs-HDD and it fails with "invalid argument".
The System is an AlpineLinux running on a SBC for a small Nextcloud.
btrfsck said /dev/sdb had Checksum verify fail, bad tree block and a Chunk-Root-Error, so i chose to remove the disk, zap the superblocks, reformat it and add it again. Now its clean again:
Opening filesystem to check...
Checking filesystem on /dev/sdb1
UUID: d6899d0f-0771-45dc-a917-dc5bc635273a
[1/8] checking log skipped (none written)
[2/8] checking root items
[3/8] checking extents
[4/8] checking free space tree
[5/8] checking fs roots
[6/8] checking only csums items (without verifying data)
[7/8] checking root refs
[8/8] checking quota groups skipped (not enabled on this FS)
found 147456 bytes used, no error found
total csum bytes: 0
total tree bytes: 147456
total fs tree bytes: 32768
total extent tree bytes: 16384
btree space waste bytes: 140646
file data blocks allocated: 0
referenced 0
This is /proc/mdstat
/home/sysad # cat /proc/mdstat
Personalities : [raid1]
md127 : active (auto-read-only) raid1 sdb1[2](S) sda1[0]
3906884608 blocks super 1.2 [2/1] [U_]
bitmap: 0/30 pages [0KB], 65536KB chunk
unused devices:
Here is the dmesg output in a bin.
This is from mdadm --examine:
/home/sysad # mdadm --examine /dev/sdb1
/dev/sdb1:
Magic : a92b4efc
Version : 1.2
Feature Map : 0x3
Array UUID : a92785da:ba629f92:b1965688:3d8c636e
Name : dirc:dataraid (local to host dirc)
Creation Time : Sat Dec 13 00:48:15 2025
Raid Level : raid1
Raid Devices : 2
Avail Dev Size : 7813769216 sectors (3.64 TiB 4.00 TB)
Array Size : 3906884608 KiB (3.64 TiB 4.00 TB)
Data Offset : 264192 sectors
Super Offset : 8 sectors
Recovery Offset : 48606208 sectors
Unused Space : before=264112 sectors, after=0 sectors
State : clean
Device UUID : 52deea94:02d8e7b0:53cf6bd7:330f9f23
Internal Bitmap : 8 sectors from superblock
Update Time : Tue Dec 16 20:04:43 2025
Bad Block Log : 512 entries available at offset 24 sectors
Checksum : 8048178 - correct
Events : 21541
Device Role : Active device 1
Array State : AA ('A' == active, '.' == missing, 'R' == replacing)
This is mdadm --detail:
/dev/md/dataraid:
Version : 1.2
Creation Time : Sat Dec 13 00:48:15 2025
Raid Level : raid1
Array Size : 3906884608 (3.64 TiB 4.00 TB)
Used Dev Size : 3906884608 (3.64 TiB 4.00 TB)
Raid Devices : 2
Total Devices : 2
Persistence : Superblock is persistent
Intent Bitmap : Internal
Update Time : Tue Dec 16 20:04:43 2025
State : clean, degraded
Active Devices : 1
Working Devices : 2
Failed Devices : 0
Spare Devices : 1
Consistency Policy : bitmap
Name : dirc:dataraid (local to host dirc)
UUID : a92785da:ba629f92:b1965688:3d8c636e
Events : 21541
Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
- 0 0 1 removed
2 8 17 - spare /dev/sdb1
Did i forget something? Advice on how to proceed would be very much appreciated.
dijak